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1.0	 Disclaimer,	Warning	&	Credits

Disclaimer

TO THE EXTENT ALLOWED BY LOCAL LAW, THIS SOFTWARE IS PROVIDED TO YOU ‘AS IS’ WITHOUT WARRANTIES OR 
CONDITIONS OF ANY KIND, WHETHER ORAL OR WRITTEN, EXPRESS OR IMPLIED. AVAGO TECHNOLOGIES SPECIFICAL-
LY DISCLAIMS ANY IMPLIED WARRANTIES OR CONDITIONS OF MERCHANTABILITY, SATISFACTORY QUALITY, NON-
INFRINGEMENT AND FITNESS FOR A PARTICULAR PURPOSE.  SOME JURISDICTIONS DO NOT ALLOW EXCLUSIONS OF 
IMPLIED WARRANTIES OR CONDITIONS, SO THE ABOVE EXCLUSION MAY NOT APPLY TO YOU.  YOU MAY HAVE OTHER 
RIGHTS THAT VARY ACCORDING TO LOCAL LAW.

TO THE EXTENT ALLOWED BY LOCAL LAW, IN NO EVENT WILL AVAGO TECHNOLOGIES OR ITS SUBSIDIARIES, AFFILI-
ATES OR SUPPLIERS BE LIABLE FOR DIRECT, SPECIAL, INCIDENTAL, CONSEQUENTIAL OR OTHER DAMAGES (INCLUD-
ING LOST PROFIT, LOST DATA, OR DOWNTIME COSTS), ARISING OUT OF THE USE, INABILITY TO USE, OR THE RESULTS 
OF USE OF THE SOFTWARE, WHETHER BASED IN WARRANTY, CONTRACT, TORT OR OTHER LEGAL THEORY, AND 
WHETHER OR NOT ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.  YOUR USE OF THE SOFTWARE IS ENTIRELY AT 
YOUR OWN RISK.  SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR DAM-
AGES, SO THE ABOVE LIMITATION MAY NOT APPLY TO YOU.

Warning.

By connecting the Development Kit to the parallel port using the I2C adapter, you are operating these two circuits to-
gether WITHOUT GALVANIC ISOLATION. DO NOT CONNECT OR DISCONNECT ANYTHING WHILE THE Development Kit 
OR THE PC IS SWITCHED ON !!! Doing so anyway may damage your PC and/or the Development Kit permanently.

Credits

Inpout32.dll port driver from http://www.logic4u.net. The Inpout32.dll parallel port driver is freeware.

CIE xy chart – Prof. Geoff Hoffman  (http://www.fho-emden.de/~hoffmann/)

Windows™ is a trademark of Microsoft Corporation.

I2C is a trademark of Royal Philips Electronics.

Other trademarks are the property of their respective owners and are hereby acknowledged.
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3.0	 Preliminary	Information	and	set	up

The parallel port should be set to “Standard Parallel 
Port” or “SPP” mode.  

The default configuration file is config.txt.  This file is 
located in the application directory. 

The default configuration file is to setup the parallel 
port to work with the Development Kit.  

The default configuration file will set the following de-
faults address.

a. The default parallel port base address is set to 
0378h or decimal 888. 

b. The default HDJD-J822 device address is 54h or 
decimal 84.  

c. The default EEPROM address is 50h or decimal 80.

The default calibration file is calfile##.txt, where ## 
represent the HDJD-J822 device address in decimal.  
The calibration file is placed in the application path 
directory. This file is not available after the ICMv1 
program installation is completed.  The calibration file 
is obtained only after calibration is done. Refer to 8.0 
Calibration Procedure section. 

If the calibration file does not exist, the thirty-one cali-
bration registers will be read from EEPROM. If the EE-
PROM does not contain calibration data, the external 
microcontroller should program the thirty-one calibra-
tion data registers, i.e. CALDATA0 to CALDATA30. If no 
external controller is available to write the thirty-one 
calibration data registers, then power on default val-
ues will be used.

The Development Kit EEPROM locations from 0 to 95 
(or 0h to 5Fh) is reserved and used by this software 
program.

2.0	 	Introduction.

This user guide describes the use of the ICMv1 pro-
gram.  The ICMv1 program is a tool to demonstrate the 
color and brightness control using the PC parallel port 
interface. It also has a calibration and measurement 
function to calibrate the Development Kit easily. 

Other HDJD-J822 system can also be demonstrated 
or calibrated, as long as the following conditions are 
fulfilled.

a. SDA and SCL pins are accessible. 

b. The embedded microcontroller, or any other external 
controller must not be accessing the SDA and SCL 
pins when this program is running. This program 
does not check whether the I2C bus is free and will 
assume that the I2C bus is always free.

Refer to section 6.0, Hardware configuration to config-
ure the program to work with the HDJD-J822 system.
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4.0	 ICMv1

The ICMv1 is usually displayed when the application 
is started.  This will control the HDJD-J822 in normal 
mode with optical feedback.

Figure 1.  ICMv1

The ICMv1 allows the user to specify color set points to 
the HDJD-J822. The set point can be specified by the 
following methods.

a. CIE xy chart color picker

b. CIE Y, x, y input text box

c. RGB colored boxes

d. Red, Green and Blue input text boxes

e. Color temperature

f. Brightness %

CIE xy chart 

Click on the CIE xy chart to select the chromaticity 
point. The chosen chromaticity point x, y coordinates is 
updated on the CIE x and y input text boxes. The Y set 
point is not changed and is at the current Y set point. 

CIE Y, x, y input textboxes

Manually enter the Y, x-coordinate, and y-coordinate 
values of the requested color.  The Y value must be less 
than 1000.  The x-coordinate and y-coordinate values 
range from 0 to less than 1.  

After the data are entered, the Send Yxy command 
button is clicked and the selected color is displayed. 

RGB colored boxes

Click on the RGB colored boxes representing the color 
desired. The RGB input text boxes, RED, GREEN and 
BLUE will be updated and the selected color is dis-
played.
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Color temperature

Click to open a list of temperature values and select 
the desired color temperature. The CIE x, y input text-
boxes is updated. The CIE Y value is at the current value 
and the chosen color temperature is obtained. 

Alternatively, the user can enter a custom color tem-
perature.  Hit the enter key to accept the custom color 
temperature.

Brightness %

Click to select the desired brightness level from a list of 
brightness available.   Alternatively, a custom bright-
ness level setting can be entered from the keyboard.

I2C Status

Green color indicates that the I2C communication 
between the computer and the HDJD-J822 is ok. Red 
color indicates that the computer could not communi-
cate with HDJD-J822.

Color Selected

This shows the sample of the color selected. It may not 
be the exact color as the color displayed.

Menu bar

The menu bar consists of File, View, Run Cal and Help. 
The View and Run Cal menu are enable only if the op-
erating mode is single.

On the View menu, click Configuration to check the 
configuration setting. Refer to 6.0 hardware configura-
tion for further information. 

On the View menu, click Calibration to read the 
calibration data.  Refer to 5.0 view calibration menu for 
further information.

Click Run Cal menu to perform calibration to obtain 
the thirty-one calibration registers values. 

Refer to 7.0 Calibration and measurement for more 
information.

On the File menu, click Exit to exit the ICM program.  
Alternatively, click “X” on the top right corner of the 
main menu.

On the Help menu, click Help to open this user guide.

On the Help menu, click About for information about 
this program.

RGB input text boxes

Manually enter RGB input text boxes. Values must 
range from 0 to 255. Click Send RGB command button 
and the selected color is displayed.

Operating Mode

There are three operating modes. 

1. Single color

2. Horizontal cycling

3. Vertical cycling

The second and third operating mode are only appli-
cable in the RGB color space. 

Click on Single Color if only one color response is 
needed.

Click on Horizontal Cycling to set to the horizontal 
cycle mode. The colors are cycled when the Send RGB 
command button is clicked. 

Click on Vertical Cycling mode to set to the vertical 
cycle mode. The brightness level are cycled with the 
same chromaticity when the Send RGB command 
button is clicked.  

When horizontal cycling or vertical cycling mode is 
selected, the View menu, Run Cal menu, CIE xy chart 
color picker, the CIE Y, x, y input textboxes and the col-
or temperature selection will be disabled. The cycling 
time will be enabled and set to default value of 2.

Click Send RGB command button to start the cycling.

To stop the display cycling, the user must set the oper-
ating mode back to single color. 

Cycle time

This input box sets the time interval for the color or 
brightness to be displayed before changing to the next 
color or brightness level.  The cycle time input text box 
can be typed only when the operating mode is either 
horizontal cycling or vertical cycling.  To change the 
cycling time, type the desired time interval.  Hit the 
enter key to accept the cycling time. 
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The View Calibration Data shows the following:

a. The loaded thirty-one calibration data, i.e. CAL-
DATA0 to CALDATA31 values and 

b. Scale ratio. 

The scale ratio is not available if the calibration file 
does not exist. The scale ratio provides correlation if 
the color set point is picked using the CIE xy chart, 
color temperature or Y, x, y input text boxes. The actual 
programmed CIE Y luminance value can be obtained 
from the equation below:

Actual programmed CIE Y luminance value:

                     Y input text box value

              Scale ratio

On the Get menu, click Default to load the HDJD-J822 
power on default calibration data values in the View 
Calibration Data. 

On the Get menu, click EEPROM.  The calibration data 
from EEPROM is loaded and shown in the View Calibra-
tion Data.

To send the calibration data shown in the View Calibra-
tion Data to the HDJD-J822, 

a. Click Send HDJD-J822 command button or

b. On the Send menu, click HDJD-J822.

Figure 2. View Calibration Data

5.0	 View	Calibration	data

On the Send menu, click EEPROM. The EEPROM is 
written with calibration data from the data shown in 
the View Calibration Data. 

Click the View menu to display the current thirty-one 
calibration data registers values programmed in HDJD-
J822, 

On the File menu, click Open to open another calibra-
tion file. The calibration data from the file is loaded and 
shown in the View Calibration Data. However, the load-
ed calibration data is not yet sent to the HDJD-J822.

On the File menu, click Save to save the calibration 
data shown in View Calibration Data to a file.

To discard the calibration data loaded in the View 
Calibration Data, click the View menu, or exit the View 
Calibration Data.

To exit the View Calibration Data,

a. On the File menu, click Close or 

b. Click Close command button or 

c. Click X on the top right corner of the View Calibra-
tion Data. 

= ——————————————————
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6.0	 Hardware	configuration	

The default values should work well with the  Develop-
ment Kit.

Figure 3.  Hardware configuration.

All numbers are in decimal.

There are four sections, LPT address, I2C options, I2C 
EEPROM device address and HDJD-J822 options.

LPT address

This value is used as the parallel port base address.  
E.g. To enter base address 378h, type the decimal value 
‘888’ in the text box below LPT address. 

I2C Options

This section setup the parallel port pins to communi-
cate with the HDJD-J822 or EEPROM.

SDA write:  Select the parallel port pins for SDA write.  
If the pin passes through an inverter, then the box be-
side the pin number needs to be changed from Nor-
mal to Inverted.

SCL write:  Select the parallel port pins for SCL write.  If 
the pin passes through an inverter, then the box be-
side the pin number needs to be changed from Nor-
mal to Inverted.

SDA read: Select the parallel port pins for SDA read.  If 
the pin passes through an inverter, then the box be-
side the pin number needs to be changed from Nor-
mal to Inverted.

SCL read: Select the parallel port pins for SCL read.  If 
the pin passes through an inverter, then the box be-
side the pin number needs to be changed from Nor-
mal to Inverted.

I2C EEPROM

The default device address is 50h or decimal 80. To pre-
vent the EEPROM from being used by this program, set 
the EEPROM Device Address to NONE. This will make 
all menus concerning with EEPROM to be invisible.  If 
an invalid address is entered, the EEPROM Device Ad-
dress will be set back to NONE

HDJD-J822 options

Device address: Set the text box to the 7-bit HDJD-
J822 device address. The 7-bit address configuration is 
as follows.
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If A1 = A0 = 0, the device address value is 1010100 or 
54h or decimal 84.

The program will use the 7-bit address to generate de-
vice write and device read address automatically. 

Sensor slope: Select either Positive or Negative. If the 
sensor characteristics are increasing voltage output 
with increasing light, then positive sensor slope is 
used. 

PWML:  Select either High or Low. If the LED drivers 
are active high enable, select Low. 

Vref Use:  Select either Internal or External. If internal 
voltage reference is used, select Internal. 

Trim Offsets: Select Yes or No. If No is selected, trim 
offset will be disabled.

Click the command button OK to accept the configura-
tion. The ICMv1 will be displayed. 

Table	1.	HDJD-J822	device	address

Note: A1 and A0 are the logic value at HDJD-J822 pins A1 and A0.  

Bit 6 5 4 3 2 1 0

Value 1 0 1 0 1 A1 A0

I2C Status

Green color indicates that the I2C communication be-
tween the computer and the HDJD-J822 is ok. 

Red color indicates that the computer could not com-
municate with HDJD-J822.

On the File menu, Click Save to save the configuration 
setting. The default file name is config.txt.

On the File menu, click Open to open a configuration 
file.  The configuration data is loaded.

To discard any changes, Click View menu or exit the 
Hardware configuration.  

“To exit the hardware configuration, click X on the top 
right corner of the Hardware configuration.
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Figure 4. Calibration/Measurement 

7.0	 Calibration	and	Measurement

This will operate the HDJD-J822 in calibration mode or 
open loop without optical feedback.

There are six sections in the calibration.

1. Gain

2. LED driver

3. Offset trimming switch

4. Offset measurement

5. Sensor and Camera reading

6. CALDATA computation

When started, the CALDATA computation, Offset Measurement, Sensor and Camera reading are invisible.

Gain Section

There are three channels, Red, Green and Blue. For each channel, click 1X if internal gain is not used. Click 2X if 2X 
internal gain is used.
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Offset trimming switch

The initial setting is no offsets. I.e. Offset switch is set 
to Off.

If offset trimming is to be used during measurement, 
click Trim.

The calibration program will automatically measure 
offsets for trimming.

As offsets are measured with all LEDs turned off, the 
LED OFF in the LED driver section will be automati-
cally set.

The Offset Measurement frame will be visible to show 
the offsets measured.

Offset measurement section

This section is not displayed if the offset trimming 
switch is set to OFF.

The offsets displayed are Offsets 0, Offset 1 and Offset 
2 and are read from offset registers OFFSET_X, OFF-
SET_Y and OFFSET_Z respectively.

To measure the offset again, click Acquire Offset com-
mand button.

Duty cycle format.

There are two formats, Duty % and Duty value. The 
duty cycle format will toggle between duty% and 
duty values each time the duty% or the duty button is 
clicked.

Initially, the format is in percentage and the Duty % 
button is visible. Click the Duty % button once to 
change the format to Duty value. The Duty button 
will be visible. Click the Duty button once to change 
the format back to Duty %. The Duty % button will be 
visible.

Duty Cycle

There are three duty cycles, R duty cycle for Red LEDs, 
G duty cycle for Green LEDs and B duty cycle for Blue 
LEDs. All the three duty cycles are set to 100% initially.

There are three scroll bars. R scroll bar for RED LEDs 
duty cycle, G scroll bar for Green duty cycle and B 
scroll bar for Blue LEDs duty cycle.

To change the duty cycles, there are two methods:

a. Drag the scroll bar corresponding to the desired 
duty cycle.

b. Enter the duty cycle in the R, G and B text boxes.

The Duty % ranges from 0 to 100 and the Duty value 
ranges from 0 to 4095.

Lock toggle

When ON, the R, G and B duty will have the same val-
ues. Any change in any of the R or G or B duty % or 
value will change the other two duty % or values au-
tomatically so that the values are the same. When OFF, 
the R, G and B duty can be set to different values.

The initial setting is ON (i.e. locked). To turn OFF, click 
LOCK once. To turn ON again, click LOCK once only 
when the LED control is set to either

a) RED ON or

b) GREEN ON or

c) BLUE ON

When the lock toggles from OFF to ON, all the duty 
% or values will be set to the same value which is the 
duty % or duty value of the LEDs that is turned ON.

Note: The lock toggle cannot be changed from OFF to 
ON if the LED control is set to LED OFF or ALL LED ON.

LED control

Click LED OFF to turn off all the LEDs.

Click RED ON to turn on only red LEDs at R duty cycle.

Click GREEN ON to turn on only Green LEDs at G duty 
cycle

Click BLUE ON to turn on only Blue LEDs at B duty 
cycle

Click ALL LED ON to turn on Red LEDs at R duty cycle, 
green LEDs at G duty cycle and blue LEDs at B duty 
cycle.
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Figure 5.  New Calibration Data

Sensor & Camera Reading section.

When the LEDs of one color are turned on, the sensor 
reading can be measured.

Click the Acquire Sensor Reading command button 
to start sensor measurement.

When the HDJD-J822 digital to analog circuitry is ac-
quiring the sensor measurement, the LED light can be 
measured with a CIE camera.

The camera values are entered for luminance Y, CIE x 
and CIE y coordinates.

Once camera values are entered, click Enter Camera 
Data to accept the values entered.

Repeat these measurements for the other two colors.

Compute CALDATA section.

When all the sensor and camera measurements are 
completed, the CALDATA computation frame will be 
displayed.

Select the camera scale value. For multicolor applica-
tions, a value of 700 is recommended. For white only 
or several white points applications, a value of 1000 is 
recommended.

Click Compute CALDATA command button to start 
calibration data processing.

Once calibration data processing is completed, New 
Calibration Data (Figure 5) is displayed.

On the CALDATA menu, click Save New CALDATA to 
save the calibration data.  The calibration data is saved 
in the file and to the Development Kit’s EEPROM. The 
file is saved in the ICMv1 program application direc-
tory.  The file name format is calfile##.txt, where ## is 
the HDJD-J822 device address.

On the CALDATA menu, click View Current CALDATA 
to compare the new CALDATA with the current CAL-
DATA. Current Calibration Data (Figure 6) is displayed.
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Figure 6.  Current Calibration Data. 

On the CALDATA menu, click Measure again to con-
tinue with calibration with the previous measurement 
data intact. 

To erase all measurements and start a new calibration, 
click X on the top left corner of the Calibration/Mea-
surement to go back to ICMv1.  Next, click Run Cal 
menu.  The Calibration/Measurement will be displayed 
and all previous measurements are erased. 



Table	2.		Data	format	at	EEPROM	address	location	0.	

8.0		 Calibration	Procedure.

1. Click the Run Cal menu. The Calibration/Measure-
ment will be displayed  

2. The R, G and B duty cycles are automatically set to 
default at 100%. Do not change the duty cycle.

3. Click on All LED ON in the LED driver section to turn 
on all LEDs

4. Click on Acquire Sensor Reading command button 
to measure the sensor reading when all LEDs turned 
on. 

 The sensor values for the three channels must range 
from 400 to 800. If any of the color channel values 
is less than 400, click 2X internal gain for that chan-
nel.

5. If offsets are to be trimmed, click Trim to start offset 
measurement and enable trim offsets. All LEDs will 
turn off after offset measurements.

6. Click RED ON to turn only the red LEDs on.

7. Click on Acquire Sensor Reading command button 
to get sensor measurements. 

8. While sensor measurement is being measured, use a 
CIE camera to measure the luminance Y values, CIE x 
coordinate and CIE y coordinate values. Click Enter 
Camera Data command button to accept readings 
entered.

9. Click on GREEN ON to turn only the green LEDs on.  
Repeat step 7 and 8. 

10. Click on BLUE ON to turn only the blue LEDs on. 
Repeat step 7 and 8. 

11. The CALDATA computation frame will be visible 
once all measurements are completed.  

12. Select the camera scale value depending on applica-
tion. For multicolor, select 700. For white only, select 
1000.

13. Click Compute CALDATA command button to start 
calibration data processing.

14. When Calibration data processing is completed, the 
New Calibration data is displayed. 

15. On the CALDATA menu, click Save New CALDATA 
to save the calibration data. The calibration data is 
saved in a calibration file. File saved is Calfile##.txt 
where ## is the HDJD-J822 device address. The file 
is saved in the default application directory.  

 If a valid EEPROM exists, the EEPROM will also be 
automatically written with the calibration data. 

 The EEPROM is written starting with the ad-
dress location 0. The address location 0 stores 
the gain setting and a marker to indicate if 
a valid calibration file exists in the EEPROM. 
 
Notes:

1. Bit 0 to 3 form a marker. Value of 1001 indicates 
a valid calibration data has been stored.

2. Gain X - Red sensor channel gain. Value is 1 if 2X 
gain is used 

3. Gain Y – Green sensor channel gain. Value is 1 
if 2X gain is used.

4. Gain Z – Blue sensor channel gain. Value is 1 if 
2X gain is used.

If no gain or 1X gain, then value is 0. 

The calibration data, i.e. CALDATA0 to CALDA-
TA30 is stored in address location 1 to 31 respec-
tively.

The EEPROM locations from 0 to 95 or 0h to 5Fh 
is reserved by this program.

16. On File menu, click Exit to return to the ICMv1.

Bit 7 6 5 4 3 2 1 0

Value GAINX GAINY GAINZ N/A 1 0 0 1
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