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Chapter 1: Getting Started

This chapter provides a brief introduction of the evaluation kit options and the software development kit (SDK) until starting 
the first measurement.

1.1  Evaluation Kits Options

The following kits are available to get started with the AFBR-S50 sensors. 

A) AFBR-S50 Evaluation Kit (Legacy)

The legacy AFBR-S50 evaluation kit is composed of the following main components:

 NXP FRDM-KL46Z (red) or STM32F401RE (blue) evaluation board: Embedded microcontroller platform 
(ARM Cortex-M0+ [red] or ARM Cortex-M4 [blue]) used to read out the AFBR-S50 time-of-flight (ToF) sensor’s data and 
exchange it with the PC.

 AFBR-S50 adapter board: The circuit board on which the AFBR-S50 ToF sensor is mounted. It delivers an out-of-box 
connection between the sensor and a microcontroller board without the need for soldering (just plug and play).

 USB-mini cable: Required to establish communication between the AFBR-S50 and your system environment (for 
example, PC, embedded application system).

B) AFBR-S50 Family Evaluation Kit

Find the hardware user guide at https://docs.broadcom.com/docs/AFBR-S50-FEK-UG.

C) BDC-AFBR-S50 ToF Sensor Board

Find the hardware description at https://www.mikroe.com/bdc-afbr-s50-tof-sensor-board.

Figure 1:  Evaluation Kit Connection Stack
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1.2  SDK Download and Setup

Download the latest SDK, including the AFBR-S50 Explorer (a graphical user interface) and the application programming 
interface (API) software, in the release section of the GitHub AFBR.S50.SDK.vX.X.X-basic.msi file:

https://github.com/Broadcom/AFBR-S50-API/releases 

Figure 2:  GitHub Release Section – SDK Download

NOTE: The version shown in the figure may vary from the actual version. 

You can also download the latest and full SDK from the Broadcom website:

https://www.broadcom.com/products/optical-sensors/time-of-flight-3d-sensors 

https://github.com/Broadcom/AFBR-S50-API/releases
https://www.broadcom.com/products/optical-sensors/time-of-flight-3d-sensors/
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1.3  Software Setup

The following steps explain the SDK installation procedure:

Step 1. Install the main application by clicking Next in the AFBR-S50 SDK setup wizard. The initial setup wizard window 
displays as follows.

Figure 3:  Initial Setup Wizard Window

Step 2: Install the main driver and all additional modules to enable full performance of the device.

Figure 4:  Installing the Device
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Step 3: Plug in the USB cable.

CAUTION! The correct USB port for this step is labeled “KL46Z” on the bottom side of the NXP board.

Figure 5:  Cable Plugged into Lower USB Port
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1.4  Updating the Device Software

When updating the AFBR-S50 SDK, the software on the evaluation kit must also be updated manually to match the installed 
GUI. This is done from the AFBR-S50 Explorer application by performing the following steps:

Step 1: Install the desired device software, as described in Software Setup, and open the AFBR-S50 Explorer app. 

Step 2: Connect the red AFBR-S50 evaluation board via the OpenSDA interface to the PC. An additional driver is not 
required. 

Figure 6:  Connecting the Red Evaluation Board with OpenSDA Labeled on the Bottom Side

Step 3: In the Explorer app, select Help > Flash Device Software > Flash…_USB.srec, and wait until the device is 
successfully flashed.

Figure 7:  Flash Device Software Option

NOTE: While the red NXP board supports USB and UART, the blue STM board offers only a UART connection.
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Step 4: When the device has flashed successfully, connect the device using the USB port labeled KL46Z, and run it as 
described in the following section. The STM32F401RE does not need to be plugged in again.

Figure 8:  Connecting the Device Using the USB Port Labeled KL46Z

NOTE: After flashing, if you fail to establish a connection to the board and if the LCD display remains blank, you might 
need to replug the USB cable into the board and repeat the flashing process.
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1.5  Performing a Distance Measurement

The following steps show how to start a continuous measurement with the connected sensor.

Step 1: Start the Explorer application, AFBR.S50.Explorer.exe, for example, by selecting AFBR-S50 SDK > AFBR S50 
Explorer from the Windows menu.

Step 2: Open a USB connection by clicking the green plug symbol.

Figure 9:  Green Plug Symbol

Step 3: Start the measurement by clicking Start.

Figure 10:  Starting the Measurement

ATTENTION: To troubleshoot problems with starting the measurement, see Troubleshooting and FAQs.



Broadcom AFBR-S50-EK-UG105
11

AFBR-S50 User Guide Evaluation Kit Quick Start Guide

Step 4: Optionally, set up the device to your needs by choosing, for example, a measurement mode and frame rate both 
before and while measuring. The changes will immediately become effective after clicking the respective Set buttons on the 
right side of each applicable parameter.

Figure 11:  Measurement Mode after a USB Connection Has Been Opened

NOTE: Information from the Configuration API section is loaded when a device is successfully connected to the Explorer 
app. The PBA default values differ among the sensor types.
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Chapter 2: AFBR-S50 Explorer

This chapter is intended to make you familiar with the graphical user interface (GUI) of the AFBR-S50 Explorer application 
and to support the evaluation of a given ToF sensor device.

The AFBR-S50 Explorer software connects to the AFBR-S50 evaluation board using the USB interface. It receives the 
measurement data from the device software running on the NXP board’s microcontroller and displays it in a convenient way. 
Furthermore, the ToF sensor device can be configured and calibrated by using the AFBR-S50 Explorer GUI.

2.1  AFBR-S50 Explorer Overview

Open the AFBR-S50 Explorer. The following window appears.

Figure 12:  AFBR-S50 Explorer Display Window

The AFBR-S50 Explorer main window consists of the following five basic elements:

1. Menu bar

2. Controller tool bar

3. Data visualization areas

4. Tool panel

5. Status bar
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2.2  Menu Bar

The AFBR-S50 Explorer menu bar includes the following three menus:

 Device

 View

 Help

Figure 13:  Device Menu

From the Device menu, options are available to open and close the USB connection, trigger measurements, create a log 
data file via a data logger to store measurement data, monitor and store the communication of the serial interface, and, once 
connected, reset the microcontroller on demand.

All data measured by the ToF sensor device can be logged to a file for plotting and evaluating the measurement results. The 
log file is saved to the entered path.

Figure 14:  Data Logging Options
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The data logger starts recording once a destination path and file are chosen. In addition, another small menu bar for the data 
logger is available.

After clicking Stop, a message appears in the Explorer application with the information and the saved number of samples. 

Figure 15:  Data Logger Recording Options

NOTE: The amount of data for the data logger output file can be changed by choosing a different data output mode from 
the Configuration API in the API section if Advanced Mode is enabled. To do so, from the Options tab, select API 
Options and enable the checkbox.

For formatting reasons, open the created log file either with an advanced text application (for example, Notepad++) or by 
importing it directly into a data analysis program. Another helpful debug feature is to perform a serial trace of all the bus 
transfers between the microcontroller and the connected device. After the serial trace starts, the application asks for a path 
to save the serial trace data. Both the measurement log data and the serial trace are saved as TXT files.

Figure 16:  View Menu

Single view modules can be enabled or disabled in the Explorer app with the View menu.
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The Help menu is used to flash the current AFBR-S50 device software to the connected microcontroller, open the latest 
status message log, reset the application values to default, and provide additional links to all necessary documentation on 
the SDK.

Figure 17:  Help Menu

2.3  Controller Tool Bar

The AFBR-S50 controller tool bar provides quick access to the most important operation elements regarding measuring and 
resetting the microcontroller. On the left, it delivers simple connect and disconnect options to open and close a connection 
via the USB port to the microcontroller on the evaluation kit board.

 Single: Sends a trigger signal to the device to perform a single measurement frame. Afterward the device goes into the 
idle state.

 Start: Starts a periodic measurement loop.

 Stop: Stops the periodic measurement loop and makes the device go into the idle state. Note that this option only stops 
the measurement loop and prevents new measurements from being triggered. However, it does not stop a currently 
ongoing measurement frame.

Figure 18:  AFBR-S50 Controller Tool Bar
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2.4  Data Visualization Views

Below the AFBR-S50 controller tool bar, all measurement data gathered by the ToF sensor device can be displayed in three 
different views: 1D Plot, 3D Plot, and Raw Data. Each of these views is introduced in the sections that follow.

Unlike the different views, the measurement status is always shown and provides information on the elapsed time of the 
measured signal, the corresponding frame rate, the dynamic configuration adaption (DCA, the number of digital averaging 
samples), the optical power, and the pixel gain.

NOTE: The displayed frame rate might differ depending on the characteristics of your serial connection (USB cable length 
and so on).

Figure 19:  Measurement Status Example

2.4.1  1D Plot View

The 1D Plot view consists of the following three plots and shows the measurement data in real time. It is the standard 
measurement view displayed after a measurement first stops. The x-axis for every chart inside the 1D plot view reflects the 
number of measurement samples.

 Range plot

 Amplitude plot

 Pixel Count plot

Figure 20:  1D Plot View
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The range plot element of the 1D Plot view can display up to three different range plots:

 Binned range: Plots the average range over all pixels that are determined by the Pixel Binning Algorithm. This value 
represents the current range in meters. 

 Smoothed binned range: Plots a time-based moving average of the binned range. To adjust the algorithm of the time-
based moving average, go to the 1D Plot Options view inside the Options tab. A greater SMA data buffer size might 
result in a slower moving visualization.

Figure 21:  Generic Data View Options

Choose between two different algorithms to calculate of the averaged measurement results:

– Simple moving average (SMA): The mean calculated from the previous N data without any weighting. The SMA data 
buffer size defines the magnitude used for SMA calculations.

– Exponentially weighted moving average (EMA): A type of infinite impulse response filter that applies exponentially 
decreasing weighting factors. The weighting for each older datum decreases exponentially but never reaches zero. 
EMA weight implies the quantifier used for the calculation of the EMA. Lower values result in less weighting of past 
measurement outcomes and thus longer averaging times.

 Sigma of binned range: The blue cloud determines the current time based on moving the standard deviation of the 
sensor signal; inside the 1D Plot Options view, choose a deviation width of 1 sigma or 3 sigma.

Figure 22:  1D Plot Options
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The different plots of the Range plot element can be turned on or off by selecting the respective checkboxes inside the 
Options panel. It is also possible to change the minimum and maximum displayed range of the respective axis or select the 
Auto Scaling option.

Figure 23:  1D Plot – Center Plot Options

Figure 24:  1D Plot Example

 Integration Energy: Calculated by the integration depth per sample multiplied by the optical output power.

 Amplitude (maximum) plot: Shows the current maximum measurement signal amplitude, which is determined by all 
pixels that are selected by the Pixel Binning Algorithm. 
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Figure 25:  Active Pixel Count vs. Saturated Pixel Count

 Active Pixel Count: The value of Active Pixel Count reveals the number of pixels that are used for calculating range and 
amplitude with respect to the current Pixel Binning Algorithm.

 Saturated Pixel Count: The value of Saturated Pixel Count reveals the number of pixels in the saturation state due to 
too much optical power received.
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2.4.2  3D Plot View

The second tab of the data visualization area opens the 3D Plot view, revealing more pixel-specific information on the 
measured range and amplitude in real time.

Figure 26:  3D Plot View

This 3D Plot view shows the retrieved measurement signal of every single pixel of the sensor’s pixel matrix.

 3D Range: The left plot shows the time-based average range values for each available pixel.

 3D Amplitude: The right plot shows the time-based average amplitude values for each available pixel. 

There is also a color axis for each plot that highlights the corresponding signal magnitude.

Hide binned pixels to see only pixels considered valid for the measurement by enabling the Hide binned pixels in plots 
option in the 3D Plot Options tab.

Figure 27:  Hide Binned Pixels Option
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Invalid pixels that do not satisfy the binning criteria will disappear from the plot.

Figure 28:  Hidden Binned Pixels

For a closer look at each pixel, zoom in and rotate the 3D plots using the mouse.

 To move a plot, click and hold the scroll wheel.

 Rotate the plots by clicking and holding the right mouse button.

 Use the scroll wheel to zoom in and out.

 Double-click the scroll wheel to reset a plot to its default point of view.
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2.4.3  Raw Data View

The Raw Data view is not visible by default; it must be enabled in the View menu first.

Figure 29:  Enabling Raw Data View

In the View menu, select Raw Data View to enable the visibility of the tab.

The Raw Data view provides additional details about each pixel’s measured range and amplitude results, including the 
corresponding mean values and signal deviations (referred to as sigma). Furthermore, Mean and Sigma of both Raw Range 
and Raw Amplitude can be displayed as either SMA or EMA weighted: Mean(s), Mean(e), Sigma(s), Sigma(e). Keep in mind 
that the choice between SMA and EMA affects the displayed values of Sigma and Mean in different ways.
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Figure 30:  Raw Data View

By enabling the Pixel Status Values checkbox, the Raw Data view displays several status flags for each pixel.

Figure 31:  Single Pixel Status

For a detailed description of the single statuses, open the API reference manual and type argus_px_status_t in the search 
field.

Choose which results to keep visible or hidden by selecting the associated Pixel View Options from the Options panel. In 
addition, the numeric format of the displayed results can be adapted.
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Figure 32:  Pixel View Options

2.5  Tool Panel Overview

This section introduces the tool panel, which is located on the right side of the Explorer GUI.

Figure 33:  Location of the Tool Panel in the GUI
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2.5.1  API Tab

In general, the API tab is organized into three categories: Generic API, Configuration API, and Calibration API. All 
functions and accessible parameters shown in this section provide an overview about the interoperability with an AFBR-S50 
sensor. As indicated in Figure 34, applicable settings have a Get button or a Set button (or both) on the right side to either 
retrieve the current parameter setting from the sensor (Get) or send a new target setting to the sensor (Set).

Figure 34:  Configuration API with Get/Set Buttons

Generic API

When a connection to the evaluation board is established, the Generic API section is populated with important information 
about the device, such as the API and Explorer version number, module type, and chipID.

Configuration API

In this category, users can modify basic sensor settings, such as the measurement mode, frame rate, dual frequency mode, 
and shot noise monitor mode, and can also optimize the Pixel Binning Algorithm settings. However, because all predefined 
settings are based on empirical data for best sensor operation, there is no need to change these settings unless there is a 
known reason.
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Figure 35:  Configuration API

Calibration API

In general, each AFBR-S50 ToF sensor is factory calibrated and immediately ready to take measurements. For system 
integration, it might be necessary to optimize the performance for a specific application, which can be carried out by the 
calibrations offered in this section of the API tab. This section consists of two main subsections: Range Offset Calibration 
and Crosstalk Calibration. 

Figure 36:  Subsections of Calibration API
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2.5.1.1  Range Offset

This parameter lets you compensate application-specific distance offsets. If the ToF sensor is part of a system that has 
another reference edge for assessing the distance, the offset between the sensor and this reference edge must be defined 
with the Range Offset parameter.

Formula: Range = RawRange – RangeOffset

Figure 37:  Range Offset

NOTE: Be careful when setting this parameter because range values might turn negative.
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2.5.1.2  Range Offset Calibration

Unlike the Range Offset parameter, which affects the binned range value, the following pixel offset from the table shown in 
Figure 38 does the same for each single pixel range by performing a calibration on a reference plane. The distance in meters 
to the reference plane can be entered in the Calibration Target Distance [m] field. After clicking the Run Range Offset 
Calibration Sequence button, the table is populated with the values and distance offsets that are written to the sensor. The 
generated calibration data can also be imported and exported for further processing or analysis. Single offset values can 
also be modified and requested by using the Get and Set buttons.

The main purpose of this calibration procedure is to enable and improve gesture detection applications by minimizing the 
range offset among the single pixels of the 32-pixel array on the receiving side. The effect of this calibration is depicted in 
Figure 39.

Figure 38:  Range Offset Calibration Table

Figure 39:  Effect of a Pixel-to-Pixel Range Offset Calibration
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2.5.1.3  Crosstalk Calibration

Crosstalk (Xtalk) calibration should be carried out for each system design with implemented AFBR-S50 sensors. It targets 
to compensate electrical crosstalk possibly generated by the application PCB, as well as optical crosstalk generated by a 
cover glass mounted above the sensor and therefore affecting its optical path.

The following example shows the calibration of electrical crosstalk. For a full calibration of electrical and optical crosstalk (for 
example, due to usage of a cover glass), refer to the AFBR-S50-XTK Crosstalk Guide.

Example Calibration Sequence for Electrical Xtalk Compensation Only

1. Blind the sensor with a foam while taking measurements, and make sure that the amplitudes are roughly as low as shown 
in the following figure. 

Figure 40:  Blinding Sensor for Xtalk Calibration

2. Click the Run Crosstalk Calibration Sequence button located in the API tab.

Figure 41:  Crosstalk Calibration Amplitude

The Xtalk vector table is immediately applied to all pixels. For further information, refer to the information in the 
AFBR-S50-XTK Crosstalk Guide.

https://docs.broadcom.com/doc/AFBR-S50-XTK-Crosstalk-Guide
https://docs.broadcom.com/doc/AFBR-S50-XTK-Crosstalk-Guide
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2.5.2  Summary Tab

The Summary tab shows current measurement results as well as generic and DCA information. As the last part of the 
measurement results section, the auxiliary parameters give the user additional information on the internal voltage and 
current levels in units of the ADC, the ASIC temperature, and environmental information, such as a background light indicator 
(in arbitrary units) and the connected shot noise amplitude.

Figure 42:  Summary Tab
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2.5.3  Options Tab

All of the available tab settings were already explained except for the API advanced options. These options give advanced 
users the possibility to further modify the PBA or DCA settings, which can be unlocked by selecting the Advanced Mode 
checkbox as shown in the following figure.

Figure 43:  Advanced Mode – API Options

When this mode is selected, the user can access more parameters in the API tab, which enable a refinement of PBA and 
DCA settings. Tooltips provide more information about each parameter.

Figure 44:  API Advanced Options Example Shown for the Configuration API Section
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2.6  Multi-Device Usage

From v1.4.4 on, multi-device controls and views via one MCU are implemented in the AFBR-S50 Explorer application. Click 
Main > Add new AFBR-S50 Device. The new views for a second device display on the screen.

Figure 45:  Add New Device

Each device can be controlled individually with its own controller tool bar. Addresses are assigned automatically.

Figure 46:  1D View of Four Sensors Running in Parallel in One AFBR-S50 Explorer Instance
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Appendix A: Troubleshooting and FAQs

This appendix contains a collection of frequently asked questions (FAQs).

A.1  Related Documents
 AFBR-S50xxxxx Data Sheets

 AFBR-S50 Software Release Notes

A.2  Different Versions of the Explorer and Controller Board
If an error message indicates that the software versions of the AFBR-S50 Explorer and microcontroller device software do 
not match, you might have older or incompatible firmware running on the evaluation board.

Figure 47:  Error Message

When upgrading to v1.x, the USB driver version is updated automatically. When downgrading manually to versions older 
than v1.x, you might need to install the older USB driver as well.

Flash the appropriate device software version onto the NXP microcontroller board by following the procedures in Updating 
the Device Software.

Figure 48:  Flashing the Device Software
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A.3  SCI Error – No Communication to Sensor

Figure 49:  SCI Error

In principle, this message can have multiple causes:

 NXP board: Most likely, the USB cable was plugged into the OpenSDA port (see Figure 8) instead of the KL46Z USB 
port.

 Another reason can be that the device software is corrupted and must be flashed again (see Section A.2, Different 
Versions of the Explorer and Controller Board). For the MikroE board, refer to the flashing guide on their website at 
https://download.mikroe.com/documents/bdc-afbr-s50-tof-sensor/HowToFlashtheReferenceDesignViaBootloader.pdf. 

 Because this error indicates a serial communication issue, it is also possible that your sensor is defective or the USB 
cable might need to be replaced.

A.4  Xtalk Calibration – 3D Plot Not Visible

Figure 50:  Xtalk Calibration

If the amplitude chart is empty, the Hide binned pixels in plots checkbox might still be enabled. To see low amplitudes while 
performing the Xtalk calibration, make sure that this option is not selected.

 

https://download.mikroe.com/documents/bdc-afbr-s50-tof-sensor/HowToFlashtheReferenceDesignViaBootloader.pdf
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A.5  Xtalk Calibration – Amplitude Error

Figure 51:  Amplitude Error Message

This error appears when the amplitude exceeds the default maximum amplitude of 20 LSB while running the Xtalk 
calibration. For Step 2 and Step 3 of the Xtalk calibration mentioned in the AFBR-S50-XTK Crosstalk Guide (necessary to 
compensate cover glasses), it might be necessary to increase this limit. This can be done in the Calibration Sequence 
Setup section at the bottom of API tab. 

Figure 52:  Calibration Sequence Setup Section

If it is not visible, you might need to enable Advanced Mode in the Options tab.

A.6  Wrong Input String Error Message

If the error shown in Figure 53 appears when starting the Explorer, you must change your system language settings to 
'english'.

Figure 53:  Error: Wrong Input String at Startup

https://docs.broadcom.com/doc/AFBR-S50-XTK-Crosstalk-Guide
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