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Introduction

Spectrometry involves the measurement of the intensity of light, and it is important to ensure that the spectrometer provides 
accurate results. This white paper explains how to perform absorbance, transmission, and reflection measurements using 
Broadcom® spectrometers and the Waves software.

Absorbance, transmission, and reflection spectroscopy is a commonly used measurement technique in analytical chemistry. 
In these measurement principles, light is directed from a broadband light source onto a sample. The spectrometer detects 
the absorbed or transmitted light of the sample. In the case of absorbance, the signal relates to the sample concentration 
and provides significant information about its chemical composition and physical properties.

Waves Graphical User Interface

Waves is free-of-charge software provided by Broadcom to operate Broadcom’s miniature spectrometers (you can download 
it at https://www.broadcom.com/products/optical-sensors/spectrometers). Waves provides a graphical user interface (GUI) 
with all the features needed to evaluate Qseries spectrometers.

Figure 1 provides an overview of the main areas of the GUI.

Figure 1:  Waves GUI

1. Exposure toolbar
2. Spectra list
3. Properties panel
4. Spectrum window
5. Display parameters
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How to Perform Absorbance and Transmission Measurements

To perform absorbance or transmission measurements, you need the following equipment at a minimum.

Light Source 

For most applications that use this type of measurement technique, a broadband light source with a wide spectral range is 
a good choice. Alternatively, light sources with a smaller bandwidth can be used (for example a tungsten-halogen lamp). 

Sample

Depending on your substance and its physical property (gas, fluid, solid), a suitable sample holder or sample chamber is 
needed. Determine what sample containment is the most suitable, and make sure that you select the correct material. For 
example, you cannot use a plastic cuvette for measuring UV signals because it is not transparent for ultraviolet light.

Spectrometer

Absorbance and transmission bands are found in many wavelengths from UV over VIS to NIR regions. Therefore, all Qseries 
spectrometers are a good choice. The spectrometer measures the intensity of the light that passes through the sample.

Fiber

Depending on your optical setup, you can work with an SMA 905 multimode fiber to guide the light between the emitter and 
the sample and between the sample and the spectrometer. Additional optics are another option to collimate the light beams 
properly through samples or to the spectrometer to perform accurate and reliable measurements.

Data Processing

You can easily transfer the measured data to a PC using a USB cable. The Broadcom Waves spectroscopy software helps 
analyze the spectra. For industrial integration, you can also work with the other serial interfaces (UART and SPI) in 
combination with the Broadcom software development kit. 
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Measurement Setup

This section shows a schematic and a picture of a typical setup for absorbance measurements.

Figure 2:  Schematic of a Typical Absorbance Measurement Setup

Figure 3:  Picture of a Typical Absorbance Measurement Setup
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Performing Measurements in the Waves Spectroscopy Software

This section describes the steps to connect the spectrometer to your PC and acquire spectra using the Waves software. 
Once your measurement setup is properly assembled and the spectrometer is connected to your PC, open the Broadcom 
Waves software and establish a connection to your spectrometer.

To establish a connection, select Device > Open Device and choose your spectrometer.

Step 1. Find the Exposure Time

Before acquiring spectra, you must set the exposure time for the sensors.

Waves allows two exposure modi:

 Auto: The spectrometer chooses the exposure time such that the sensor load is approximately 70%.

 Manual: You can select the desired exposure time.

Unless there is requirement on the exposure time set by your application needs, Broadcom recommends acquiring one 
spectrum in auto mode to let the spectrometer find the ideal exposure time.

NOTE: Ensure that the light intensity during this measurement corresponds to the maximum intensity during all further 
evaluations. For example, for absorption measurements, use a dummy reference sample with no absorption (for 
example, an empty cuvette).

The spectrometer will automatically determine the exposure time.
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NOTE: Once the exposure time is set automatically, change to manual exposure. The spectrometer will keep the initially 
determined exposure time for all future measurements.

The exposure time and the sensor load level are displayed in the Properties panel of the Waves GUI and are saved as 
metadata for each spectrum.
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Once you have properly set the exposure time, Broadcom recommends that you acquire a background and reference 
spectrum to calibrate the system. Both calibration steps are implemented in the Exposure toolbar of the Waves GUI.

Figure 4:  Predefined Functions for Background and Reference Spectra Calibration in the Waves GUI

Step 2. Acquire the Background Spectrum

To take a background spectrum, turn off the light source, keep the adjusted exposure time, and click Take Background 
Spectrum ( ) from the Exposure toolbar (#2 in Figure 4). To activate background spectrum subtraction for future 
measurements, click the Use background spectrum icon (#4). The icon changes from a black disc to a black disc with rays, 
indicating that background spectrum subtraction is activated ( ). If a spectrum is later taken, the background 
spectrum is automatically subtracted from the measured spectrum, eliminating unwanted background signals.

Step 3. Acquire the Reference Spectrum

Acquire a reference spectrum for either reflection spectroscopy or transmission and absorption spectroscopy.

Reflection Spectroscopy

To take a reference spectrum for reflection spectroscopy, a white reference sample is required to calibrate the setup for 100% 
reflection. However, all real-world reference samples have a reflection of less than 100% and an uneven spectral distribution. 
Therefore, for accurate measurements, a reference spectrum must be supplied for the reference sample. To take a reference 
spectrum, place the white reference sample where the measured sample will be later placed. Then, keep the adjusted 
exposure time and temporal averaging, and click Take Reference Spectrum ( , #3 in Figure 4). In the dialog window that 
follows, specify a data file that includes a calibrated spectrum of your reference sample. After selecting Use Reference 
Spectrum ( , #5 in Figure 4), measure the reflectivity spectra.

Transmission and Absorption Spectroscopy

To take a reference spectrum for transmission or absorption spectroscopy, turn on the light source again, remove the sample 
or replace it by a reference sample, keep the adjusted exposure time and temporal averaging, and click Take Reference 
Spectrum ( , #3 in Figure 4). After selecting Use Reference Spectrum ( , #5 in Figure 4), take spectra of the 
sample for measuring absorption or transmission. If the light source does not cover the full range of the spectrometer, the 
calculated spectrum might show large amounts of noise outside the wavelength range of the light source. This is normal and 
reflects the fact that the measurement has a large uncertainty at these wavelengths.

These measurements are quite sensitive to changes in the sample illumination. If in doubt, take another reference spectrum 
to ensure that it is still valid. Accurate calibration and sample preparation are essential for measurement performance.

21

1. Indicates that sensitivity correction is applied.
2. Click to acquire a background spectrum.
3. Click to acquire a reference spectrum, for example 

of the light source.
4. Click to activate background subtraction.
5. Click to activate reference background subtraction.

3 4 5
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The following table provides a brief overview of the typical preparation steps for reflection, transmission, and absorption 
spectrum measurements.

Providing high reproducibility between setups in the preceding steps is crucial.

Using an optimized exposure time and adequate background and reference spectrum calibration, nonuniformities between 
setups (for example, intensity differences of the light sources and the quality of the light coupling into the spectrometer) can 
be corrected, and very high uniformity between measurement setups can be achieved.

Figure 5 shows an absorption measurement of a 40 mg/100 ml K2CrO4 using two Broadcom miniature spectrometers with 
different entrance slit settings (20 mm and 100 μm) to simulate variations in the uniformity of the light source and the quality 
of the light coupling into the spectrometer. Excellent reproducibility between the measurements of the two miniature 
spectrometers with different hardware settings is obtained by properly calibrating the measurement setup as previously 
described in Step 1, 2, and 3.

Figure 5:  Absorption Spectrum of 40 mg/100 ml of Potassium Dichromate

Table 1:  Summary of Calibration Steps to Prepare the Setup for Measurements

Step Measurement Type Exposure Applied Corrections Notes

1. Exposure time Auto  None  Light source on. 

2. Background spectrum for subtraction Manual  Sensitivity correction
 Light source off. 
 To apply the sensitivity correction, select 

Device > Select Processing Steps. 

3. Reference spectrum Manual
 Sensitivity correction
 Background spectrum

 Activate background subtraction 
(measured in Step 2).

 Light source on.
NOTE: The setup must be identical to the final 
setup. A dummy sample must be inserted to 
also correct for the absorbance of the probe 
holder and the like.

Start the absorbance measurement. Manual

 Sensitivity correction
 Background spectrum
 Reference spectrum 

subtraction

 Activate reference spectrum subtraction 
(measured in Step 3).

 Light source on. 

Absorption of 40 mg/100 ml K CrO2 4
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Additional Tips and Hacks

This section provides additional guidance on the basic features of the Waves software.

Calibrate the Sensitivity

All Broadcom miniature spectrometers are calibrated for nonlinearity coefficients, offset, and sensitivity. The calibration data 
is stored in the EEPROM. You can turn on/off these calibrations under Device > Select Processing Steps in the Exposure 
toolbar.

Change the Y-Axis Scale

Select File > Options > Acquisition > Unit for relative intensities.

The transmittance is usually written as a percentage.

The spectral absorbance is sometimes defined as a base 10 logarithm and sometimes as a natural (base e) logarithm. In 
the Waves software, both options are available.
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Save the Spectrum

In the default settings, each acquisition overwrites the previously acquired spectrum. To keep all spectra, activate “Keep all 
new spectra” ( ). All acquired spectra will now be visible in the Spectra list. To select or unselect individual spectra to be 
displayed in the Spectra window, select the box.

To save the acquired spectra, select File > Save Spectrum. The standard format in which the spectra are saved is a *.spz 
file. The format is a tab-delimited ASCII file and can be imported like a *.txt file to many common software tools such as MS 
Excel and Python.

Compare with Various Spectra

To compare your latest spectra with reference data or older data, you can import spectra using the import function of Waves 
(File > Add Spectrum to File to List).

Manipulate/Analyze Multiple Spectra

In the Modify menu of the Exposure toolbar, the Waves GUI provides you with the basic features to work with the acquired 
spectra: 

 Normalization

 Smoothing

 Arithmetic operations

 Averaging

If you need any help, contact Broadcom at support.spectrometer@broadcom.com. 



Copyright © 2023–2025 Broadcom. All Rights Reserved. The term “Broadcom” refers to Broadcom Inc. and/or its 
subsidiaries. For more information, go to www.broadcom.com. All trademarks, trade names, service marks, and logos 
referenced herein belong to their respective companies.

Broadcom reserves the right to make changes without further notice to any products or data herein to improve reliability, 
function, or design. Information furnished by Broadcom is believed to be accurate and reliable. However, Broadcom does 
not assume any liability arising out of the application or use of this information, nor the application or use of any product or 
circuit described herein, neither does it convey any license under its patent rights nor the rights of others. 

http://www.broadcom.com

	Introduction
	Waves Graphical User Interface
	How to Perform Absorbance and Transmission Measurements
	Measurement Setup
	Performing Measurements in the Waves Spectroscopy Software
	Step 1. Find the Exposure Time
	Step 2. Acquire the Background Spectrum
	Step 3. Acquire the Reference Spectrum
	Reflection Spectroscopy
	Transmission and Absorption Spectroscopy


	Additional Tips and Hacks
	Calibrate the Sensitivity
	Change the Y-Axis Scale
	Save the Spectrum
	Compare with Various Spectra
	Manipulate/Analyze Multiple Spectra


